menu
Fórum Adianti
menu Menu
Erro ao carregar a classe instalada via composer Senhores, Estou obtendo o erro em anexo, quando instancio um objeto de duas classes de bibliotecas de geração de boletos. As duas tem funções parecidas, mas sempre o erro é apresentado como se não tivesse encontrado a classe. Não lembro de ter realizado nenhuma mudança no ambiente (meu computador), e o código funcionava de boa. Já verifiquei que o diretório está na pasta /vendor, co...
AR
Erro ao carregar a classe instalada via composer  
Senhores,

Estou obtendo o erro em anexo, quando instancio um objeto de duas classes de bibliotecas de geração de boletos. As duas tem funções parecidas, mas sempre o erro é apresentado como se não tivesse encontrado a classe. Não lembro de ter realizado nenhuma mudança no ambiente (meu computador), e o código funcionava de boa. Já verifiquei que o diretório está na pasta /vendor, conforme já esperado.

  1. <?php
  2. $cedente = new \OpenBoleto\Agente(SystemPreference::getPreference('geral_razao_social'), 
  3.                 SystemPreference::getPreference('geral_cnpj'), 
  4.                 SystemPreference::getPreference('geral_logradouro').', '.SystemPreference::getPreference('geral_numero').' - '.
  5.                 SystemPreference::getPreference('geral_bairro'), 
  6.                 SystemPreference::getPreference('geral_cep'), 
  7.                 (new Cidade(SystemPreference::getPreference('geral_cidade')))->nome
  8.                 (new Cidade(SystemPreference::getPreference('geral_cidade')))->estado->uf);
  9. ?>

Curso completo Meu Negócio Pronto
Use para si, ou transforme em um negócio: Inclui aulas e códigos-fontes
Gestor de conteúdo (SITE) + Loja Virtual (E-Commerce) + Emissor de Notas para infoprodutos


Meu negócio pronto Quero me inscrever agora!

Comentários (1)


HL

Alisson, bom dia!

Já tive problemas semelhantes com as bibliotecas da Gerencianet, alterei meu ambiente para o Ubuntu e rodou tranquilamente.