menu
Fórum Adianti
menu Menu
Mostrar imagem de perfil no template html Olá pessoal. Estou usando o theme3 do adianti 5 e fiz um TFile para que o usuário pudesse enviar uma imagem de perfil ao editá-lo (no template). O problema está para trazer a imagem para o layout.html através da tag {userphoto} .. já fiz as edições no index.php e no LoginForm.class.php mas mesmo assim ele não vai.. e já está no banco certinho o nome da imagem....
FT
Mostrar imagem de perfil no template html  
Olá pessoal. Estou usando o theme3 do adianti 5 e fiz um TFile para que o usuário pudesse enviar uma imagem de perfil ao editá-lo (no template).
O problema está para trazer a imagem para o layout.html através da tag {userphoto} .. já fiz as edições no index.php e no LoginForm.class.php mas mesmo assim ele não vai.. e já está no banco certinho o nome da imagem.

Pacotão Dominando o Adianti Framework 7
O material mais completo de treinamento do Framework.
Curso em vídeo aulas + Livro completo + Códigos fontes do projeto ERPHouse.
Conteúdo Atualizado! Versão 7.4


Dominando o Adianti 7 Quero me inscrever agora!

Comentários (6)


NR

Você tentou inspecionar o código para ver qual html está gerando?
FT

Obg pela resposta. Estou usando o codigo <img src="images/{userphoto}" class="img-circle" style="border:3px solid white" height="100" width="100"/> para que em {userphoto} viesse o nome da imagem que está no banco, mas ele não traz nada e quando inspeciono o html ele fica apenas o caminho até images/
NR

Poste as modificações realizadas.
FT

na minha tabela systemuser adicionei a coluna "photo" onde fica o nome da imagem e a imagem fica na pasta chamada imagens
na index.php inseri a seguinte linha juntamente com as demais semelhantes:

  1. <?php 
  2. $content  str_replace('{userphoto}'TSession::getValue('userphoto'), $content); 
  3. ?>


na LoginForm.class.php na classe onlogin acrescentei também a linha

  1. <?php 
  2. TSession::setValue('userphoto'$user->photo);
  3. ?>


e na layout.html a seguinte linha

<img src="images/{userphoto}" class="img-circle" style="border:3px solid white" height="100" width="100"/> para que a tag fosse substituída pelo nome da imagem

**postei apenas os trechos do código pois assim acho que fica mais fácil^^



NR

Felipe, confira o valor que está vindo da sessão, pois se no html está aparecendo o caminho até "images/" é porque o replace está sendo feito e trocando "{userphoto}" por null.
FT

Obrigado pela ajuda Nataniel. Era isto mesmo! Hoje peguei para refazer e foi necessário retornar a este tópico.